Follow

What version of Apple TV is needed to use the NFHS Network app?

The NFHS Network Apple TV app is only available on 4th Generation Apple TV devices. 

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

0 Comments

Article is closed for comments.